Soutenir Vision du Web dans son partage de logiciels et de ressources libres

Ce mineur crée de la monnaie numérique Monero pour soutenir Vision du web.
Merci de désactiver votre bloqueur de publicité.
Aucune publicité ne sera affichée.
Le mineur utilise les ressources de votre machine pour créer gratuitement de la monnaie numérique.
Le montant des donations pour Vision du web est de 0.058587088301867 Monero.

Utiliser Git avec Eclipse

De Wiki. Analyse, Communication, Développement, Hacking.
Aller à : navigation, rechercher
Naviguer sur le site : Accueil du site - Les annuaires - Les éditoriaux - Le forum - Les outils - Les projets
 

Sommaire

Eclipse

Développé originellement par IBM à partir de Visual Age, Eclipse est un EDI, Environnement de Développement Intégré.
Le logiciel a été rendu open-source et est maintenant maintenu par la fondation Eclipse Foundation Software.
Cette fondation est composée d'un grand nombre de membres et est dirigée par un conseil d'administration.
La conception de Eclipse est complètement modulaire ce qui fait d'Eclipse une boite à outils facilement modifiable et extensible.
La license de Eclipse permet de fournir des plug-ins open sources comme des plug-ins closed-source.
Eclipse gère un grand nombre de langages de programmation. (PHP, C, C++ ...)
Eclipse RCP (Rich Client Platform) sert de socle à 29,672,070 applications.
Consulter la page Eclipse Marketplace : http://marketplace.eclipse.org
Eclipse.png

Installation

Installer JAVA

Eclipse a besoin de JAVA pour fonctionner.
Le dossier JRE de JAVA peut être placé dans le dossier de Eclipse pour ne pas avoir à installer JAVA.
Installer OpenJDK 8 pour permettre à Eclipse et à d'autres programmes de fonctionner sans avoir à placer le dossier JRE dans le dossier de Eclipse.

Installer Eclipse

Le site officiel de Eclipse : https://www.eclipse.org
La version de Eclipse lors de la rédaction de cette page est Eclipse Photon.
Télécharger et installer Eclipse depuis la page de chargement officielle de Eclipse : https://www.eclipse.org/downloads/
La version de Eclipse pour développer avec PHP est Eclipse PHP Development Tools (PDT).
Télécharger et installer Eclipse PDT depuis la page de chargement officielle des paquets Eclipse : https://www.eclipse.org/downloads/eclipse-packages/
Distribution PDT : Les outils essentiels pour tout développeur PHP, y compris le support du langage PHP, le client Git, Mylyn et les éditeurs pour JavaScript, HTML, CSS et XML.
La version de Eclipse pour développer pour le web est Eclipse IDE for JavaScript and Web Developers.
Télécharger et installer Eclipse pour le Web depuis la page de chargement officielle des paquets Eclipse : http://www.eclipse.org/downloads/packages/eclipse-ide-javascript-and-web-developers/photonr
Les outils essentiels pour tout développeur JavaScript, y compris JavaScript, HTML, CSS, support des langages XML, client Git et Mylyn.
Eclipse peut également être directement installé depuis les dépôts GNU/Linux.
sudo apt-get install eclipse
Capture d'écran de Eclipse Mars.

Ajouter Eclipse au menu Cairo-Dock

Ajouter un raccourci personnalisé pour Cairo-Dock sous GNU/Linux permettant de lancer Eclipse.
Utiliser la commande suivante :
Exec=/bin/bash /home/USERNAME/Eclipse/eclipse
Sinon, rendre /home/USERNAME/Eclipse/eclipse exécutable :
sudo chmod u+x /home/USERNAME/Eclipse/eclipse
Puis, utiliser :
Exec=/home/USERNAME/Eclipse/eclipse

Ajouter une entrée dans le menu XFCE

Ajouter une entrée dans le menu XFCE de Debian 8.7 Jessie :
Ajouter une entrée dans le dossier /usr/share/applications/ qui s’appellera Eclipse.desktop pour voir le raccourci ajouté au menu XFCE.
[Desktop Entry]
Type=Application
Name=Eclipse
GenericName=Eclipse
Comment=Eclipse PDT : PHP.
Icon=/home/userone/USER-SERVEUR/Eclipse/php.png
Exec=/home/userone/USER-SERVEUR/Eclipse/eclipse
Terminal=false
StartupNotify=false
Categories=Development;

Configurer Eclipse

Ajouter le dossier de travail Workspace

A l'ouverture Eclipse demande un emplacement pour son dossier Workspace.
Le choix de l'emplacement du dossier Workspace n'est pas important pour un usage minimaliste.
Le choix de l'emplacement du dossier Workspace est important dans le cas d'un serveur Web local devant utiliser les ressources présentes dans le Workspace.
Placer le dossier Workspace dans votre dossier interprété par le serveur Web, souvent, le dossier www, ou, le dossier htdocs, ou encore, le dossier html.
Par exemple pour Xampp sous GNU/Linux : /opt/lampp/htdocs/Workspace

Auto complétion

Pour configurer l'auto complétion de Java, aller dans Fenêtre/Préférences/java/editor/contentAssist/
Pour configurer l'auto complétion de PHP, aller dans Fenêtre/Préférences/php/editor/contentAssist/

Mettre à jour

Help > Check for Updates.

Changer la langue

Eclipse en français avec le pack de langues du projet Babel.
Sauvegarder le dossier Eclipse et le dossier de travail avant de tester Babel.
Penser que Eclipse plante très souvent avec Babel installé. Rester en version anglaise de préférence.
Installer le pack de langue, d'après le site officiel :
Trouver le lien à utiliser pour le pack de langue de la version courante : http://www.eclipse.org/babel/downloads.php
Open the install wizard with 'Help' > 'Install new software...'
Add the Babel p2 repository: http://download.eclipse.org/technology/babel/update-site/R0.15.1/oxygen
Select/install your language pack of choice
Choisir Babel Language Packs for Eclipse in French (92% traduit.)
Suivant. Valider la licence. Fini.
Patienter durant le chargement.
Redémarrer Eclipse.

Changer le thème graphique

Fenêtre > Préférence > Généralités > Apparence > Thème.
Choisir le thème sombre.
Redémarrer Eclipse.

Changer l'encodage

Pour travailler sur un environnement hétérogène (Mac, Windows, Linux), UTF-8 est définit comme la valeur par défaut.

Changer l'encodage général au niveau d'Eclipse

Window > Préférences > Généralités > Types de contenu, cliquer sur Texte, ajouter la valeur UTF-8 pour l'encodage.
Window > Préférences > Généralités > Workspace, cliquer sur "Codage du fichier texte" et choisir la valeur UTF-8.
Passer le Default (Cp1252) en Other UTF-8

Changer l'encodage d'un projet, en cliquant droit sur le projet

Sélectionner "Properties" dans le menu contextuel
Dans la partie "Info", plus précisément "Text file encoding", sélectionner UTF-8

Changer l'encodage d'un fichier, en cliquant droit sur le fichier

Sélectionner "Properties" dans le menu contextuel
Dans la partie "Info", plus précisément "Text file encoding", sélectionner UTF-8

Paramétrer le navigateur par défaut

Utiliser Firefox Developer par défaut. Fenêtre > Préférences  > Généralités > Choisir ou ajouter un navigateur web.

Rafraîchir les fichiers

Paramètres de rafraîchissement des fichiers et sauvegarde.
- Générer automatiquement : Est coché par défaut avec Eclipse Luna.
- Sauvegarde automatique du code source avant génération : Cocher dans Préférences > General > Workspace > Save automatically before build
- Recharger automatiquement un fichier qui a été modifié sans passer par Eclipse : Cocher dans Préférences > General > Workspace > Refresh On Access
- F5 permet également de rafraîchir un fichier Eclipse.

Outils à utiliser

Liste des tâches

La liste des tâches (Task List) permet de créer une liste de tâches à faire.
Fenêtre > Afficher la vue > Tâches

Historique de versions de fichiers

Depuis Eclipse Ganymede, la gestion des versions de fichiers est prise en charge avec le Local History.
Consulter la liste des révisions dans l'écran du bas, dans l'onglet Commun.

Utiliser Git avec Eclipse

Configurer les informations du profil utilisateur de GIT

Il faut créer un utilisateur local pour pouvoir travailler avec GIT.
Aller dans : Fenêtre > Préférences > Équipe > Git > Configuration
Add Entry pour ajouter une identité avec pour valeur la clé et son contenu : user.email & user.name
L'identité de l'utilisateur est représentée par un nom et un mail qui seront utilisés dans l'historique des modifications.
User.email.png User.name.png
Pour Windows, ils sont enregistrés dans le dossier USER.
C:\Users\NOM-HOTE\.gitconfig
[user]
name = Zer00CooL
email = [email protected]
Les paramètres du système ne sont généralement pas utilisés sur les plates-formes GNU/Linux.
Fenêtre > Préférences > Équipe > Git > Configuration > Onglet System Settings.
Je supprime par la suite le répertoire créé pour l'utilisateur Zer00CooL et le premier repo local placé dans le dossier git par défaut.
Je conserverais le dossier du projet importé depuis Github.

Convertir les délimiteurs de ligne

Pour éviter les problèmes il est essentiel de s'assurer que tous les développeurs sur un projet ont les mêmes paramètres pour la ligne-séparateurs.
Les équipes utilisent habituellement la version Unix. Windows et Macintosh la comprennent et la traitent bien.
Pour convertir des fichiers existants : Fichier -> "Convertir les délimiteurs de ligne en" et choisir Unix.
Les fichiers textes seuls sont sélectionnés par défaut pour être convertis.

Utiliser MyLyn

La version Eclipse PDT met à disposition MyLyn.

Importer depuis un projet Github

Importer le projet sans avoir besoin de configurer Eclipse

En cas d'utilisation du client Github, il suffit d'importer directement le projet Git hébergé sur Github.
La configuration de Git est importée avec le projet existant et permet le commit en local puis de push vers Github.
Afficher la perspective GIT
Fenêtre > Ouvrir la perspective > Autre ... Git
Un onglet Git Repositories est affiché.
Cliquer sur la ligne du profil GIT.
Utiliser le bouton : Clone a Git Repository and add the clone to this view. Choisir Github. Donner le nom du projet pour le retrouver sur Github.
Exemple : bot-cannabis-educatif
Search
Sélectionner le repo et cliquer sur suivant.
Choisir la branche master et cliquer sur suivant.
Laisser la configuration par défaut et cliquer sur Terminer.
Une nouvelle ligne apparaît dans l'onglet Git Repositories.
Le sous dossier Working Tree contient les fichiers du projet.

Ouvrir et modifier un fichier du projet

Cliquer sur le fichier cannabis-bot-irc.php pour ouvrir le fichier.
Faire des modifications et enregistrer le fichier.

Commit le fichier du projet en local

La fenêtre du bas propose l'onglet Git Staging.
On peut lire Unstaged Changes (1). Cliquer sur le bouton + pour ajouter le fichier à la liste des fichiers qui seront commit.
Renseigner le message pour le commit.
Laisser le nom de l'auteur et du comitter par défaut.
Cliquer sur Commit.

Push to Upstream le fichier du projet vers Github

Revenir à l'onglet Git Repositories sur la gauche.
La branche master affiche une flèche vers le haut et le chiffre 1 pour indiquer qu'un commit est en attente d’envoi sur le serveur Github.
Clic droit sur la ligne et Push to Upstream.
Renseigner le nom d'utilisateur Github et le mot de passe de Github.
Valider.
(J'ai un message d'erreur si je demande à Eclipse de conserver le mot de passe.)
Rafraîchir la page Github qui contient le code du projet : https://github.com/ZerooCool/bot-cannabis-educatif
Le code a bien été mis à jour.

Consulter l'historique de Git

Dans la fenêtre du bas, aller dans l'onglet Git Reflog pour consulter les dernières modifications.
Double cliquer sur une modification pour afficher une nouvelle fenêtre d'informations. En bas à gauche de cette fenêtre, deux onglet sont disponibles : Commit et Diff.
Utiliser l'onglet Diff pour voir les dernières modifications apportées au fichier.

Créer un dépôt local avec deux branches

Créer un projet PHP.
Donner un nom : HelloWorld.
Terminer.
La perspective PHP est proposé. Accepter.
Créer un nouveau fichier PHP dans le projet HelloWorld.
Donner un nom au fichier : HelloWorld.php
Ajouter une ligne de code : echo "Hello World";
Enregistrer le fichier.
Cliquer droit sur le projet PHP.
Team > Partager le projet.
Cliquer la case, utiliser ou créer le repository dans le dossier parent du projet.
Sélectionner le projet.
Cliquer sur le bouton : Create Repository. L'adresse sera par exemple de la forme /opt/lampp/htdocs/Eclipse-Workspace/HelloWorld (/.git)
Terminer. Un dossier de Repository est maintenant disponible.
La première ligne du projet dans la vue de l'Explorateur de Projet à gauche affiche : HelloWorld [HelloWorld NO-HEAD]
Cliquer droit sur le projet PHP.
Team > Commit > Ajouter les fichier avec le bouton ++ ainsi qu'un commentaire. Valider le commit.
La première ligne du projet dans la vue de l'Explorateur de Projet à gauche affiche : HelloWorld [HelloWorld master]
La branche principale est créée.
Cliquer droit sur le projet PHP.
Team > Switch To > New Branch
Nommer la nouvelle branche HelloWorld_2 et laisser les options par défaut. Valider.
La première ligne du projet dans la vue de l'Explorateur de Projet à gauche affiche : HelloWorld [HelloWorld HelloWorld_2]
La branche secondaire est créée.

Commit des changements sur une branche

Cliquer droit sur le projet PHP.
Team > Switch To > master pour revenir sur la branche principale master.
Changer le code du fichier HelloWorld.php pour echo "Hello World Master";
Enregistrer le fichier modifié.
Team > Commit > Ajouter le fichier modifié avec le bouton ++ ainsi qu'un commentaire. Valider le commit.
Cliquer droit sur le projet PHP.
Team > Switch To > HelloWorld_2 pour revenir sur la branche secondaire HelloWorld_2.
On constate que HelloWorld_2 affiche le code echo "Hello World"; alors que la branche master qui a été modifiée affiche echo "Hello World Master";
Le contenu des deux branches est donc bien différent.
Modifier le code de la seconde branche pour echo "Hello World Secondaire";
Team > Commit > Ajouter le fichier modifié avec le bouton ++ ainsi qu'un commentaire. Valider le commit.
Cliquer droit sur le projet PHP.
Team > Switch To > master pour revenir sur la branche principale master.

Merge une branche vers une autre branche

Nous sommes sur la première branche master qui pourrait contenir un code peu avancé prêt à être remplacé par la branche secondaire HelloWorld_2.
Cliquer droit sur le projet PHP.
Team > Merge > Select a branch or tag to merge into the 'master' branch
On choisi la branche HelloWorld_2 qui va être merge dans la branche master.
Merge options : Commit (Commit the result). Fast forward options : If a fast-forward, only update the branch point.
Valider le bouton Merge.
La branche master affiche maintenant echo "Hello World Secondaire";
Le code en développement de la branche secondaire a bien été merge vers la branche principale.
En cas de conflit, il est possible de sélectionner l'information à conserver, un code délimitera les zones de conflits pour une correction manuelle.
Le merge n'est pas automatique à ce moment la et le code nécessite une relecture.

Notes

Le commit est prioritaire pour enregistrer les modifications apportées sur une branche. Bien penser à commit son code avant de merge.
Changer de perspective pour changer de branche plus facilement : Fenêtre > Perspective > Ouvrir la perspective > Autre > Git

Créer un patch

Créer un patch est également une option intéressante de Eclipse.
Le patch permet d'appliquer des changements sur un fichier initial.
Lors de l'utilisation du patch, un dossier "a" est créé.
Placer dans ce dossier le fichier initial.
Appliquer le patch, ou, le patch inverse.
Le fichier initial qui a été copié dans le dossier "a" se voit modifié par le patch.
Compléter par la suite pour créer et utiliser un patch.

Liens complémentaires

// Source : http://tutoriels.meddeb.net/tag/git-eclipse/
// Source : http://tutoriels.meddeb.net/tuto-git-utiliser-git-avec-eclipse/
// Source : http://tutoriels.meddeb.net/tuto-git-utiliser-git-avec-eclipse-publier-tagger-visualiser/

Importer depuis un dépôt local

Fichier / Importer. 
Project from existing GIT source.
Local repository.
Import.
Fin.

Configurer EGit

Il n'est pas nécessaire d'installer MyLyn dans le cas d'une utilisation basique de EGit.
Installer simplement EGit en utilisant http://download.eclipse.org/egit/updates comme adresse et installez uniquement Eclipse EGit. 
Source : https://eclipsesource.com/blogs/tutorials/egit-tutorial/
Source : https://www.php-geek.fr/configurer-et-utiliser-egit-eclipse.html
Source : https://www.supinfo.com/articles/single/5342-utilisation-git-avec-eclipse
Source : https://openclassrooms.com/fr/courses/1803496-egit-quand-git-s-invite-dans-eclipse
Source : http://help.eclipse.org/luna/index.jsp?topic=%2Forg.eclipse.egit.doc%2Fhelp%2FEGit%2FUser_Guide%2FUser-Guide.html

Ignorer des fichiers

Utiliser le fichier .gitignore pour ignorer des fichiers lors de la synchronisation.

Interpréteur PHP

Configurer PHP pour exécuter du code localement

Configuration minimaliste

Dans mon cas, un serveur Xampp est installé sur GNU/Linux Debian Jessie.
Depuis un script PHP "Bonjour le monde" cliquer sur la petite flèche noire à droite de l'icone vert play, qui permet de lancer l'interprétation du code PHP.
Créer le dossier de travail de Eclipse dans le dossier du site utilisé par défaut par le serveur web.
Indiquer le chemin vers le fichier à exécuter vers le dossier de travail.
/Eclipse-Workspace/Hello-World/helloworld.php
Le rendu dans le navigateur sera : http://localhost/Eclipse-Workspace/Hello-World/helloworld.php
Le rendu sera : Hello World

Configuration standard

Configurer PHP depuis Fenêtre > Préférences > PHP > Servers
Ajouter un environnement PHP exécutable en cliquant sur le bouton Add.
Sous onglet Server
Donner un nom à cette configuration, typiquement la version de PHP utilisée. Par défaut : Default PHP Web Server.
Base URL : http://localhost
Document Root : /opt/lampp/htdocs/Eclipse-Workspace/

Installer xdebug

Installer xdebug sur un serveur local Xampp

Installer xdebug sur Xampp.

Paramétrer Eclipse avec xdebug

Depuis Fenêtre > Préférences > PHP > Debug > Debuggers
XDebug doit être sélectionné comme débogueur PHP.
Configurer Xdebug avec localhost dans la liste de choix Accept remote session (JIT)
Depuis Fenêtre > Préférences > PHP > Servers
Sous onglet Debugger : Choisir xdebug une fois xdebug installé.

Utiliser xdebug

Ouvrir un fichier php.
Aller dans le menu Exécuter et sélectionner Déboguer.
La touche F11 permet d'interpréter la page sur le navigateur intégré à Eclipse.
Si la page PHP n'affiche pas de contenu, vérifier que le lien appelé correspond bien à l'emplacement du fichier.
Sinon, aller dans Exécuter > Exécuter les configurations.
Si la fenêtre de debogue a été fermée, et, refuse de s'ouvrir à nouveau, vérifier que le carré rouge ait bien été cliqué pour arrêter le mode debogue.
La fenêtre du bas, Problèmes, affichera par exemple les variables qui ne sont pas utilisées dans le script.
La fenêtre de droite, Struct, affichera par exemple les variables présentes dans le script.
Des modèles de debogue peuvent être créés à l'aide de points d'arrêts.
Ok.png Source : http://unitstep.net/blog/2009/01/26/getting-xdebug-to-work-with-apachexampp-to-debug-php/

Sauvegarder Eclipse

Avant chaque installation de nouveaux composants sur Eclipse, faire une copie du répertoire qui contient le programme Eclipse ainsi que du dossier de travail qui contient votre projet.

Les raccourcis de Eclipse

Édition

Raccourcis Action
Ctrl+Espace Assister au contenu (dont autocomplétion)
Alt+/ Complétion du mot
Ctrl+Maj+Espace Informations de contexte
Ctrl+Maj+Y Mettre en minuscules
Ctrl+Maj+X Mettre en majuscules
Alt+Maj+O Marquer/démarquer les occurrences
Ctrl+C / Ctrl+Insert Copier
Ctrl+X / Maj+Suppr Couper
Ctrl+V / Maj+Insert Coller
Ctrl+Alt+Haut / Ctrl+Alt+Bas Dupliquer la ligne en cours ou des lignes sélectionnées (en haut ou en bas)
Ctrl+D Effacer la ligne
Ctrl+Suppr Effacer le mot suivant
Ctrl+Arrière Effacer le mot précédent
Ctrl+Maj+Suppr Effacer jusqu'à la fin de la ligne
Ctrl+Maj+Entrée Insérer une ligne au-dessus
Maj+Entrée Insérer une ligne en dessous
Home Aller en début de ligne
Fin Aller en fin de ligne
Alt+Bas Descendre de N lignes
Alt+Haut Monter de N lignes
Ctrl+Droite Aller au mot suivant
Ctrl+Gauche Aller au mot précédent
Ctrl+Bas Scroller vers le bas
Ctrl+Bas Scroller vers le haut
Ctrl+Home Aller en haut du fichier
Ctrl+Fin Aller en bas du fichier
Ctrl+Maj+Q Basculer en diff rapide
Ctrl+1 Proposer une solution rapide
Ctrl+Z Défaire
Ctrl+Y Refaire
F2 Afficher la description
Ctrl+Maj+Insert Basculer en mode insertion
Alt+Maj+A Active/désactive le mode colonne
Ctrl+Maj+L Afficher tous les raccourcis

Sélection

Raccourcis Action
Alt+Maj+Bas Restaurer la dernière sélection
Ctrl+A Sélectionner tout
Alt+Maj+Haut Sélectionner élément englobant
Alt+Maj+Droite Sélectionner l'élément suivant
Alt+Maj+Gauche Sélectionner l'élément précédent
Ctrl+Maj+Droite Sélectionner le mot suivant
Ctrl+Maj+Gauche Sélectionner le mot précédent
Maj+Fin Sélectionner jusqu'à la fin de la ligne
Maj+Home Sélectionner jusqu'au début de la ligne

Recherche

Raccourcis Action
Ctrl+K Rechercher le suivant
Ctrl+Maj+K Rechercher le précédent
Ctrl+F Rechercher/remplacer
Ctrl+J Rechercher incrémentalement
Ctrl+Maj+J Rechercher anti-incrémentalement (ie. inversée)
Ctrl+G Rechercher la déclaration dans le « workspace »
Ctrl+Alt+G Rechercher le texte dans le « workspace »
Ctrl+H Ouvrir la boite de recherche
Ctrl+Maj+G Rechercher les références dans le « workspace »
Ctrl+Maj+U Rechercher les occurrences

Refactoring

Raccourcis Action
Alt+Maj+C Modifier la signature d'une méthode
Alt+Maj+L Extraire une variable locale
Alt+Maj+M Extraire une méthode
Alt+Maj+R Renommer
Alt+Maj+T Ouvrir le menu de refactoring

Source

Raccourcis Action
Ctrl+Maj+/ Commenter/décommenter le bloc
Ctrl+Maj+M Importer l'élément
Ctrl+Maj+J Initier la Javadoc
Ctrl+Maj+F Formater
Ctrl+I Indenter le bloc
Ctrl+Maj+O Organiser les imports
Alt+Maj+S Ouvrir le menu rapide de source
Alt+Maj+Z Ouvrir le menu rapide d'entourage (pour entourer avec if, try, for, etc.)

Debug

Raccourcis Action
Alt+Maj+D Ouvrir le menu de lancement de debug
F11 Relancer le dernier debug
F11 Relancer le dernier debug
F8 Continuer
Ctrl+F2 Terminer
F5 Aller dans l'instruction (entrer)
F6 Aller à l'instruction suivante
F7 Sortir
Ctrl+Maj+B Ajouter/supprimer un point d'arrêt

Run

Raccourcis Action
Alt+Maj+X Ouvrir le menu de lancement
Ctrl+F11 Relancer la dernière exécution

Fichier

Raccourcis Action
Ctrl+F4 / Ctrl+W Fermer
Ctrl+Maj+F4 / Ctrl+Maj+W Fermer tout
Ctrl+N Créer nouveau (via boite d'assistance)
Alt+Maj+N Créer nouveau (via menu)
Ctrl+P Imprimer
Alt+Entrée Afficher les propriétés
F5 Rafraichir
F2 Renommer
Ctrl+S Sauver
Ctrl+Maj+S Sauver tout

Navigation

Raccourcis Action
Alt+Gauche Retourne au précédent (dans l'historique)
Alt+Droite Retourne au suivant (dans l'historique)
Ctrl+L Aller à une ligne (en indiquant son numéro)
Ctrl+Maj+P Aller à l'accolade correspondante (de l'ouvrante à la fermante, et réciproquement)
Ctrl+Maj+Bas Aller au membre suivant (pour passer d'une méthode à la suivante par exemple)
Ctrl+Maj+Haut Aller au membre précédent
Ctrl+Q Aller au dernier emplacement modifié
Ctrl+Alt+H Ouvrir la fenêtre d'appel hiérarchique
F3 / Ctrl+Clic Aller à la déclaration d'un élément
Maj+F2 Voir la Javadoc externe
Ctrl+Maj+R Ouvrir une ressource (fichier/classe/etc.)
Ctrl+Maj+T Ouvrir un type (classe)
Ctrl+F3 Voir la structure (d'une classe par exemple)
F4 Voir la hiérarchie du type cible
Ctrl+Maj+H Voir la hiérarchie d'un type
Ctrl+T Voir la hiérarchie rapide du type cible
Ctrl+O Voir le « outline » rapide du type cible
Alt+Maj+W Voir menu pour le type cible
Ctrl+F10 Afficher le menu de la vue
Ctrl+M Maximiser/rétablir la vue/perspective
Ctrl+F6 Aller à l'éditeur suivant
Ctrl+Maj+F6 Aller à l'éditeur précédent
Ctrl+F7 Aller à la vue suivante
Ctrl+Maj+F7 Aller à la vue précédente
Ctrl+F8 Aller à la perspective suivante
Ctrl+Maj+F8 Aller à la perspective précédente
Ctrl+E Switcher rapidement d'éditeur
Ctrl+Maj+E Switcher d'éditeur
Ctrl+Maj+L Voir la liste des raccourcis

Bibliographie

Ok.png Le wiki officiel : http://wiki.eclipse.org/Main_Page
Ok.png Des informations sur Eclipse : http://planeteclipse.org/planet/
Ok.png Les raccourcis de Eclipse par Thierry Leriche Dessirier, un article Développez : https://thierry-leriche-dessirier.developpez.com/tutoriels/eclipse/raccourcis/
Ok.png FAQ Eclipse de Développez : https://eclipse.developpez.com/faq/?page=plateform#frenchEclipse

NAVIGATION

COMPRENDRE LA BLOCKCHAIN PAR LA PRATIQUE

Obtenir gratuitement de la cryptomonnaie sur internet : https://www.visionduweb.eu/forum/bitcoin/1597-gagner-des-bitcoins-miner-des-bitcoins

PARTICIPER ET PARTAGER

Vous êtes sur le HackerSpace de Vision du Web.
Les pages présentées sur le wiki évoluent tous les jours.
Certaines recherches sont peu abouties et incluent des erreurs.
Pour participer sur le wiki, créer un compte utilisateur en haut à droite.
Pourquoi utiliser GNU/Linux ? Y'a moins bien, mais, c'est beaucoup plus cher.
GNU/Linux, hackerspace, opensource, logiciels libres et transition écologique.
La recherche interne du wiki permet de trouver le contenu qui vous intéresse.
Les informations présentes sur cette page sont issues d'une recherche personnelle.
Identifiez-vous pour poser vos questions sur la page de discussion de VisionDuWeb.
Améliorer le contenu des pages en faisant des propositions depuis l'onglet discussion.
Pour écrire en Markdown : Éditeur - Générateur de tableau 1 - Générateur de tableau 2.
Vous pouvez partager les articles du wiki avec l'ensemble de la communauté des internautes.
Les recherches sur la sécurité servent à administrer et protéger votre système informatique.
Les informations du wiki ne doivent pas servir à nuire à autrui ou à un système informatique.
De nombreux outils gratuits sont listés et disponibles dans la boîte à outils de Vision du web.
D'autres pages du wiki peuvent correspondre à vos attentes. La liste de toutes les pages du wiki.

SOUTENIR LE WIKI

Soutenir le wiki avec des Bitcoins.
Soutenir le wiki avec des Bitcoins Cash.
Soutenir le wiki avec des Bitcoins Gold.
Soutenir le wiki avec des Bitcore (BTX).
Soutenir le wiki avec des Blackcoins.
Soutenir le wiki avec des Bytecoins.
Soutenir le wiki avec des Clams.
Soutenir le wiki avec des Dash.
Soutenir le wiki avec des Monero.
Soutenir le wiki avec des Dogecoins.
Soutenir le wiki avec des Ethereum.
Soutenir le wiki avec des Ethereum Classique.
Soutenir le wiki avec des Litecoins.
Soutenir le wiki avec des Potcoins.
Soutenir le wiki avec des Solarcoins.
Soutenir le wiki avec des Zcash.